Delayed email delivery
Incident Report for F5 App Infrastructure Protection
Resolved
Sendgrid has indicated that email delivery issues have been resolved.
Posted Nov 20, 2015 - 11:57 EST
Monitoring
Email-based alerts, user invitations and trial signup invites may be delayed due to intermittent issues with our email provider, Sendgrid. We're monitoring their status and will update when service is restored.
Posted Nov 20, 2015 - 10:12 EST